Tag Archives: excel

Excel’de Bir Sayıyı 0,5 Yuvarlama

Ondalıklı bir sayıyı 0,5 ölçülere yuvarlamak isteyelim. Mesela 162,4 sayısı 162,5 olacak. 122,7 sayısı 122,5 olacak. 18,1 sayısı 18 olacak. A2 hücresinde bulunan bir sayıyı aşağıdaki hazır fonksiyon ile kolayca 0,5 yuvarlayabilirsiniz. =YUVARLA(A2/0,5 ; 0)*0,5 İngilizce Excel’lerdeki karşılığı =ROUND(A2/0,5 ; 0)*0,5

Kapalı Bir Excel Dosyasından Veri Çekme

Excel’de başka bir sayfadan veri çekmek için aşağıdaki kod kullanılır.

Bu kodu parçalara ayırırsak, [verioku.xlsx] kısmı içerisinden veri alınacak dosyayı gösterir. Sayfa1 ifadesi verioku.xlsx dosyası üzerinde veri alınacak sayfayı ve son olarak da B2 ifadesi Sayfa1 üzerindeki B2 hücresini gösterir. Bunu VBA içerisinde değişken bir hale getirip, parametrik bir altyordam (sub) olarak tanımlarsak bir… Read More »

Excel’de ScreenUpdating Özelliği

Excel‘de VBA kullanan bir çok kişi bir sayfadaki verileri döngü ile tararken işlemin çok uzun sürmesinden şikayetçi olur. Mesela 1000 satırlık bir sayfamız olsun. VBA ile makro hazırlayarak belli bir kritere uyan hücrelerin yanına “gokhanca.com” yazdırmak isteyelim. İşlem çok basit:

Bu işlemi yaparken neredeyse 20-30 saniye beklediğimiz olur. Hatta iç içe döngü kullansaydık süre… Read More »

Excel’de Süzmeleri Kapatmak

Süzme işlemi Excel‘de çok kullanılan bir işlem. Özellikle iş hayatında koca koca tablolar tutanlar için birebirdir. Fakat bunun en sinir bozucu yanlarından biri birden fazla süzme açıldığında kapatmak için tek tek kontrol etmek. Bazen öyle oluyor ki bütün süzmeleri kapattım sanıyorsunuz ama kapanmamış bir süzme kalmış olabiliyor. Bunun için iki farklı metot ile tüm süzmeleri… Read More »